PowerBoots Install 'A-ha!'

Jul 15, 2009 at 10:16 PM

First, awesome product!

Ran into an issue on install and wanted to share so others might benefit.

My Config:

XP SP2 x32

PoSh V2 CTP3 w/ Quest, SCOM, and PSCX snapins loaded


Ran into two issues. The first was reflected by the following error:

Error loading the extended type data file:

Pscx, C:\Program Files\PowerShell Community Extensions\Typedata\FileSystem.ps1xml(19) : Error in type "System.IO.FileInfo": Member "Basename" is already present. 

This was resolved by removing PSCX. The second issue was trickier to diagnose because there was no actual error message, but trying to follow the tutorial failed because New-BootsWindow didn't exist. Running 'Get-Command -module PowerBoots' showed only a couple of commands that, once I traced my way through the PSM1 file, I realized were not true cmdlets. As a test, I tried manually registering the PoshWpf.dll file in the GAC using InstallUtil. This caused the following security related inner exception:

That assembly does not allow partially trusted callers

As it turns out, the company I am working at presently redirects their 'My Documents' for all users to a network location. I cut the PowerBoots dir from the Modules directory in my 'My Documents' and moved it to the default directory - '%windir%\System32\WindowsPowerShell\v1.0\Modules' and re-launched PowerShell and imported the module again. This time everything worked fine.

The only reason I find this odd is because I have loaded snapins from network locations before provided my security policy was set right and I had unblocked the file. No worries. At least I got it working.

I hope this will help someone else.