Issue running samples

Mar 16, 2010 at 11:21 PM


Windows 7 Pro, Powershell 2.0, Powerboots GPL3 June 18 2009 version

I followed the instructions to install Powerboots:

- unpacked under Z:\WinScripts7

- ran the commands in the PS prompt:


import-module powerboots

PS Z:\ScriptsWin7> get-module powerboots

ModuleType Name                      ExportedCommands                                                          
---------- ----                      ----------------                                                          
Manifest   powerboots                {Add-BootsFunction, Get-BootsModule, Remove-BootsContentProperty, New-Bo...

But when I start the samples, there's an error message:

PS Z:\ScriptsWin7> .\PowerBoots\Samples\Samples.ps1 2
Cannot resolve alias 'Boots' because it refers to term 'New-BootsWindow', which is not recognized as a cmdlet, function, operable program, or script file. Verify the term and try again.
At Z:\ScriptsWin7\PowerBoots\Samples\Samples.ps1:107 char:9
+    Boots <<<<  { Button -Content "Push Me" }
    + CategoryInfo          : ObjectNotFound: (Boots:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : AliasNotResolvedException

Is something missing in the way I installed Powerboots?




Mar 17, 2010 at 3:04 AM

That's odd... what do you get if you run:

Get-Command -Module PowerBoots -Type Cmdlet


Import-Module PowerBoots\PoshWpf
Get-Command -Module PoshWpf

Mar 17, 2010 at 7:50 PM

I've ran the above commands and there's no output from Powershell:

PS Z:\ScriptsWin7> Get-Command -Module PowerBoots -Type Cmdlet

PS Z:\ScriptsWin7> Import-Module PowerBoots\PoshWpf

PS Z:\ScriptsWin7>Get-Command -Module PoshWpf

I have a login script and was thinking of using the advanced features of Boots for friendly GUI messages to users upon logon.

Mar 17, 2010 at 8:05 PM

That's odd. In your Z:\ScriptsWin7\PowerBoots\ folder, do you not have a PoshWpf.psd1 and PoshWpf.dll, because that's all I can think of that would cause that: missing files, or files in the wrong place.

Mar 17, 2010 at 10:15 PM

I do have PoshWpf.psd1 and PoshWpf.dll in Z:\ScriptsWin7\PowerBoots\.

They are not empty files. I can look at the properties/details of the DLL file.

The .psd1 file has this beginning content:

I also tried with PowerBoots min release, but no su@{
Author="Joel Bennett"
Copyright="© 2009, Joel Bennett, released under the Ms-PL"
Description="A WPF GUI Module for PowerShell, inspired by Ruby's Shoes"

I don't see 'New-BootsWindow' in the output of Get-Command -Module PowerBoots.

I also tried the sample in the Powerboots min release, but no success.

Definitely strange.

May 7, 2010 at 3:58 PM

I am, apparently, not paying enough attention. Obviously you're having the same problem as these guys: because I keep forgetting to release code

I've been adding features internally, but not releasing it for months now. Anyway, the fix is simple, and detailed on that page ... and now that I've been reminded how long it's been since I released, I'll get a new release out as soon as I can.